88 Prelude Speedo not working

Third Generation Honda Prelude topics

Moderators: RedRacer, spiffyguido

[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable
andrewc1968
Prelude Enthusiast
Posts: 2
Joined: Thu Jun 05, 2014 7:34 pm
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

88 Prelude Speedo not working

Postby andrewc1968 » Thu Jun 05, 2014 9:14 pm

Hi Im new to the forum and have recently purchased an 88 prelude
The odometer is working but the speedo is not. It was working when i purchased the car but it has just stopped operating
Does anyone have any ideas on how to fix this
Thanks

User avatar
spiffyguido
Moderator
Posts: 2196
Joined: Fri Nov 11, 2005 2:55 am
Prelude Model: 1991 SE-SR
Location: Alberta, Canada
Contact:

Re: 88 Prelude Speedo not working

Postby spiffyguido » Fri Jun 13, 2014 1:21 pm

Check the speedo cable. I believe on the 88 Preludes a speedometer cable is still used. It will run from the firewall down into the top side of the transmission and may be retained by a small metal clip. These can fall off sometimes.

If instead of a cable you have a VSS sending unit (small metal box on top of transmission), check the wiring.
Image



andrewc1968
Prelude Enthusiast
Posts: 2
Joined: Thu Jun 05, 2014 7:34 pm
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: 88 Prelude Speedo not working

Postby andrewc1968 » Sun Jun 15, 2014 6:22 am

The speedo cable is connected fine as it is still driving the odometer
There is an electronic connection between that and the Speedo that i am not sure is functioning correctly
I have taken another dash out of a car at a wreckers and had it checked to be sure its Ok before i install
Thanks for the answer anyway




[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Return to “3rd Generation 1988-1991”

Who is online

Users browsing this forum: No registered users and 4 guests