ECU code 9

Third Generation Honda Prelude topics

Moderators: RedRacer, spiffyguido

[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable
ns_wrestler130
Lude Dude
Posts: 16
Joined: Thu Sep 23, 2010 7:44 pm
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

ECU code 9

Postby ns_wrestler130 » Sat Apr 05, 2014 12:36 pm

I have a 90 so with a freshly rebuilt b21a1. Driving to work the other day the engine light came on and is flashing a code 9. The car is running horribly, extremely rich, rough and backfiring, basically not drivable. I have tested the CYL sensor and wiring as per the FSM, also checked the wiring, and everything is coming back with proper resistance. Should be between 750-1000 and I'm reading around 940. I also tested the TDC and Crank sensors, all which tested within specs. This leads me to think the culprit may be the ECU itself. Does anyone have other ideas of what to check? And also will an ECU from a 92 prelude work for my car? I'm really kind of lost and I've already put a ton of money into this car getting the motor rebuilt. Thank you all in advance.

User avatar
spiffyguido
Moderator
Posts: 2196
Joined: Fri Nov 11, 2005 2:55 am
Prelude Model: 1991 SE-SR
Location: Alberta, Canada
Contact:

Re: ECU code 9

Postby spiffyguido » Wed Apr 09, 2014 7:40 am

I've heard that the wiring for the distributor can also trigger a code 9. Have you checked all that thoroughly as well? You would've certainly had the dizzy off for your rebuild.
Image



ns_wrestler130
Lude Dude
Posts: 16
Joined: Thu Sep 23, 2010 7:44 pm
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: ECU code 9

Postby ns_wrestler130 » Wed Apr 09, 2014 12:45 pm

I did check the wiring visually and I also checked both sensors inside the distributor and the wiring to the ecu following the procedure in the FSM. All looked good. Although the distributor looks pretty bad inside, lots of rust and build up, I cleaned it the best I could and no change.

User avatar
spiffyguido
Moderator
Posts: 2196
Joined: Fri Nov 11, 2005 2:55 am
Prelude Model: 1991 SE-SR
Location: Alberta, Canada
Contact:

Re: ECU code 9

Postby spiffyguido » Mon Apr 14, 2014 7:21 am

Just reading your original post again.

You say that the code popped up while you were driving. Had it been fine for a while? Or was this the first time you had it out since the rebuilt.

And to answer your other question, no, an ECU from a 92 won't work. An ECU from a B21A1 is the only one you can use.
Image



ns_wrestler130
Lude Dude
Posts: 16
Joined: Thu Sep 23, 2010 7:44 pm
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Re: ECU code 9

Postby ns_wrestler130 » Mon Apr 14, 2014 8:32 am

Yes it has been fine for a few thousand miles. And that's what I thought on the ECU, thanks for clarifying.

User avatar
spiffyguido
Moderator
Posts: 2196
Joined: Fri Nov 11, 2005 2:55 am
Prelude Model: 1991 SE-SR
Location: Alberta, Canada
Contact:

Re: ECU code 9

Postby spiffyguido » Wed Apr 16, 2014 8:08 am

Have you been resetting the ECU after each bit of maintenance you've done to see if it clears the code?
Image






[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1266: count(): Parameter must be an array or an object that implements Countable

Return to “3rd Generation 1988-1991”

Who is online

Users browsing this forum: No registered users and 4 guests