Car and Dash lights wont start

Third Generation Honda Prelude topics

Moderators: RedRacer, spiffyguido

91prelude
Prelude Enthusiast
Posts: 8
Joined: Thu Jun 06, 2013 5:35 pm

Car and Dash lights wont start

Postby 91prelude » Thu Jan 09, 2014 5:10 pm

Hey Peeps,
My car wouldn't start, so i went and gave it a jump hoping that would help it. At that time the dash lights were working as i tried to jump start it. When i bought a new battery and tried to start it, the dash lights and the car wont start. Whats wrong? Sorry for bothering you guys with rookie questions :?

User avatar
spiffyguido
Moderator
Posts: 2196
Joined: Fri Nov 11, 2005 2:55 am
Prelude Model: 1991 SE-SR
Location: Alberta, Canada
Contact:

Re: Car and Dash lights wont start

Postby spiffyguido » Sat Jan 11, 2014 11:56 pm

Have you checked your fuses? If the dash lights aren't coming on that seems like a potential blown fuse somewhere, perhaps caused by your attempted jump start.

91prelude
Prelude Enthusiast
Posts: 8
Joined: Thu Jun 06, 2013 5:35 pm

Re: Car and Dash lights wont start

Postby 91prelude » Sun Jan 12, 2014 7:31 pm

Ill Check em! Will that keep the car from starting? There is also a little green light that is blinking by my ebrake. Is that a symbol for something? Thanks for your response Spiffy

User avatar
spiffyguido
Moderator
Posts: 2196
Joined: Fri Nov 11, 2005 2:55 am
Prelude Model: 1991 SE-SR
Location: Alberta, Canada
Contact:

Re: Car and Dash lights wont start

Postby spiffyguido » Mon Jan 13, 2014 1:37 pm

Can't think what the green light by your e-brake might be.

Blown fuses can prevent your car from starting though.

91prelude
Prelude Enthusiast
Posts: 8
Joined: Thu Jun 06, 2013 5:35 pm

Re: Car and Dash lights wont start

Postby 91prelude » Tue Jan 14, 2014 4:35 pm

Still not starting. When I try my engine is kicking, just not starting. I checked my spark plugs and in the well to the very right, there is oil in it. Is that the cause? I also checked all my fuses and they seem fine, my dashlights still wont turn on when i turn the key to is second position. Thank you for taking the time to help me.

91prelude
Prelude Enthusiast
Posts: 8
Joined: Thu Jun 06, 2013 5:35 pm

Re: Car and Dash lights wont start

Postby 91prelude » Tue Jan 14, 2014 5:35 pm

Never mind Spiff! I got it starting. Changed all fuses, maybe there was on i didn't see... Changed spark plugs and cleaned the distributor cap. Put a new alternator in as well, so hopefully it keeps on going! Thanks for the help, I love this forum. Thanks guys

User avatar
spiffyguido
Moderator
Posts: 2196
Joined: Fri Nov 11, 2005 2:55 am
Prelude Model: 1991 SE-SR
Location: Alberta, Canada
Contact:

Re: Car and Dash lights wont start

Postby spiffyguido » Wed Jan 15, 2014 7:59 am

Awesome. Very glad to hear that you're all sorted.

For the benefit of others who may read this thread, which fuse ended up being the source of the trouble? ECU?

91prelude
Prelude Enthusiast
Posts: 8
Joined: Thu Jun 06, 2013 5:35 pm

Re: Car and Dash lights wont start

Postby 91prelude » Thu Jan 16, 2014 4:42 pm

I think it was the IG 2 main fuse? If that makes sense. I really just changed all of them. That one just looked the worst

91prelude
Prelude Enthusiast
Posts: 8
Joined: Thu Jun 06, 2013 5:35 pm

Re: Car and Dash lights wont start

Postby 91prelude » Wed Jul 22, 2015 11:07 pm

So I went to turn on the car after work and it didn't start... Bought a new battery and I replaced the 70 Battery Main Fuse. when I connect the battery my side blinkers flash on and off, when I try to start the car it wont start :/ Any ideas. Im going to replace my cables and spark plug again, Just cant find a blown fuse, could it be something else?
Appreciate the time

User avatar
spiffyguido
Moderator
Posts: 2196
Joined: Fri Nov 11, 2005 2:55 am
Prelude Model: 1991 SE-SR
Location: Alberta, Canada
Contact:

Re: Car and Dash lights wont start

Postby spiffyguido » Sat Jul 25, 2015 2:06 pm

What exactly happens when you try to start the car?

Do the warning lights come on as they normally would before startup? Does the engine turn over but not fire up? Or is just dead?

The fact that your blinkers are coming on when you connect the battery makes me wonder if you have a short somewhere. Unless your hazard switch is on, those obviously shouldn't be coming on like that.




Return to “3rd Generation 1988-1991”

Who is online

Users browsing this forum: No registered users and 4 guests