Welcome, guest to our forums!

Hello and welcome. It looks like you're new here. PreludeDriver.com is a resource for anyone interested in Honda Preludes, whether you own a Prelude or not. We're always looking to meet new people, so please Register for an account and introduce yourself. Don't be nervous if you're just starting out with Honda Preludes. We help new people all the time.

1989 honda prelude power sterring issue

Third Generation Honda Prelude topics

Moderators: RedRacer, spiffyguido

1989 honda prelude power sterring issue

Postby militos » Thu Feb 11, 2010 5:09 pm

Hello, my 1989 honda prelude after I start and warm up the engine and try to take of from a stop/parked state, if I turn the sterring wheel to fast it will get hard to turn, and make some skuiching noises,,sounds like the sterring pump is giving up?? ( so, I relax, and turn the sterring wheel slow and than it wont make noise).

car drives fine, from L.A. to San Francisco california often, is just wen I turn the sterring wheel like at a light, or turning the sterring wheel to park,,,,it makes that evil noice,,,,,I' tired of calling my neighbords attention!!

please help, or I will pee in this car.
1989 Honda Prelude, 2.0Si, 5speed. stock.
thanks.

militos.
militos
Lude Dude
 
Posts: 13
Joined: Mon Jun 29, 2009 11:53 am

Advertisement

Don't want to see this ad? Register for an account.

PreludeDriver.com
 

Re: 1989 honda prelude power sterring issue

Postby spiffyguido » Thu Feb 11, 2010 6:34 pm

Is the noise coming from the power steering pump, or the power steering belt. If it is a squeeling noise from the belt, just tighten the belt.

If it is a groan/whine coming from the pump, check to make sure your power steering fluid is topped up. If the fluid is fine, then your power steering pump is probably failing.
User avatar
spiffyguido
Moderator
 
Posts: 2150
Joined: Fri Nov 11, 2005 2:55 am
Location: Alberta, Canada
Prelude Model: 1991 SE-SR

Re: 1989 honda prelude power sterring issue

Postby militos » Fri Feb 12, 2010 1:51 pm

I'm going to check the Belt, sounds like it is just the belt, I got the timming belt just replaced, and the water pump, so the mechanic may be lefted the power sterring belt loose.

the fluid is fine, the pump dosn't make any noises....so, hopefully is just a loose power sterring belt.

I'let you all know.

thanks for the response.

militos.
militos
Lude Dude
 
Posts: 13
Joined: Mon Jun 29, 2009 11:53 am

Re: 1989 honda prelude power sterring issue

Postby militos » Mon May 03, 2010 3:55 pm

sorry for the delay,,I found out that my mechanic was a litte be retarded and he lefted the sterring pump loose after he replaced the timming belt, and water punp,,,I just tighted down the mounting screws with my 12 mm wrench,,and problem solved.

thanks.
militos.


militos
Lude Dude
 
Posts: 13
Joined: Mon Jun 29, 2009 11:53 am


Return to 3rd Generation 1988-1991

Who is online

Users browsing this forum: No registered users and 2 guests