96 prelude missfiring on all 4 but runs fine h23a3

Fourth Generation Honda Prelude topics

Moderators: RedRacer, spiffyguido

bb2owner
Prelude Enthusiast
Posts: 2
Joined: Sun Jan 19, 2014 3:03 am

96 prelude missfiring on all 4 but runs fine h23a3

Postby bb2owner » Sun Jan 19, 2014 3:46 am

I have a 96 prelude with an h23a3 and I have a cel for misfiring on all cylinders and a random got a diagnose and said everything was fine but didn't know why it was throwing those coded any help!!!

User avatar
spiffyguido
Moderator
Posts: 2196
Joined: Fri Nov 11, 2005 2:55 am
Prelude Model: 1991 SE-SR
Location: Alberta, Canada
Contact:

Re: 96 prelude missfiring on all 4 but runs fine h23a3

Postby spiffyguido » Mon Jan 20, 2014 12:22 pm

Which code(s) exactly are you getting?

viewtopic.php?f=3&t=14

KCKippenhan
Prelude Enthusiast
Posts: 8
Joined: Sun Jan 19, 2014 12:39 am

Re: 96 prelude missfiring on all 4 but runs fine h23a3

Postby KCKippenhan » Tue Jan 21, 2014 1:55 am

Your computer might possibly be sensing misfiring upon startup. Does your car start hard or right away? Could have been that you were misfiring at one time and the problem went away but the codes remained in your computer's memory. I would clear the codes and see if the cel comes back on.

bb2owner
Prelude Enthusiast
Posts: 2
Joined: Sun Jan 19, 2014 3:03 am

Re: 96 prelude missfiring on all 4 but runs fine h23a3

Postby bb2owner » Tue Jan 21, 2014 5:10 am

It starts right up I lost the paper that they gave me with all the codes on it but the car starts right up no problem and pepboys cleared the codes for me and when I was on my way home it came back on would changing the ecu help?

User avatar
spiffyguido
Moderator
Posts: 2196
Joined: Fri Nov 11, 2005 2:55 am
Prelude Model: 1991 SE-SR
Location: Alberta, Canada
Contact:

Re: 96 prelude missfiring on all 4 but runs fine h23a3

Postby spiffyguido » Wed Jan 22, 2014 7:32 am

Changing the ECU is very likely not required. As KCKippenhan mentioned, you're probably just having some sensors providing feedback to the ECU that raise an error code.

This links describes how you can check the codes yourself. It's very easy:

viewtopic.php?f=3&t=14

KCKippenhan
Prelude Enthusiast
Posts: 8
Joined: Sun Jan 19, 2014 12:39 am

Re: 96 prelude missfiring on all 4 but runs fine h23a3

Postby KCKippenhan » Wed Jan 22, 2014 6:50 pm

I highly doubt your ecu is the problem, I wouldn't recommend replacing it at this time. The first thing I would do is get a list of every code currently activating the cel. P0300 is random multiple misfires, P0301 is a cylinder 1 misfire, P0302 is a cylinder 2 misfire, and so on. Many times you get those codes along with another one such as an O2 sensor, egr, temperature sensor code, etc. Any of those codes would not necessarily cause your car to run any differently, but could trigger other codes and cause your cel light to come on. Be aware though, that a code is merely a starting point. An egr code can point to many different problems, so don't just replace parts because there is a code. Faulty wiring, vacuum leaks, carbon build up, etc can often time be the real problem. If you'd like, get me all of your codes and I'll help suggest things you can do to narrow down your cause of the problem. Hope this helps, good luck.




Return to “4th Generation 1992-1996”

Who is online

Users browsing this forum: No registered users and 4 guests